Commit 2a7e71c9 authored by Nick Mathewson's avatar Nick Mathewson 👁
Browse files

Fix "run_check_subsystem_order.sh" to use $PYTHON.

Previously it just used /usr/bin/env/python, which would fail if we
only had a "python3" binary.

Fixes bug 40095; bugfix on 0.4.4.1-alpha.
parent d8370331
o Minor bugfixes (testing):
- When running the subsystem order check, use the python binary
configured with the PYTHON environment variable. Fixes bug 40095;
bugfix on 0.4.4.1-alpha.
......@@ -12,6 +12,7 @@ if ! test -x "${INCLUDES_PY}" ; then
fi
"${TOR}" --dbg-dump-subsystem-list | \
"${PYTHON:-python}" \
"${INCLUDES_PY}" --check-subsystem-order - "${abs_top_srcdir}/src"
echo ok
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment