Commit 31c7a65d authored by Nick Mathewson's avatar Nick Mathewson 🎨
Browse files

Document required autotools versions

CentOS 6 is roughly the oldest thing we care about developers still
using, and it has autoconf 2.63 / automake 1.11.  These are both
older than openssl 1.0.0, so anybody who can't upgrade past those
probably can't upgrade to a modern openssl either.  And since only
people building from git or editing configure.ac/Makefile.am need to
use autotools, I'm not totally enthused about keeping support for
old ones anyway.

Closes ticket 17732.
parent d3af4f4e
......@@ -4,8 +4,9 @@
# See LICENSE for licensing information
# "foreign" means we don't follow GNU package layout standards
# 1.9 means we require automake vesion 1.9
AUTOMAKE_OPTIONS = foreign 1.9 subdir-objects
# 1.11 means we require automake vesion 1.11
# "subdir-objects" means put .o files in the same directory as the .c files
AUTOMAKE_OPTIONS = foreign 1.11 subdir-objects
ACLOCAL_AMFLAGS = -I m4
......
o Minor features (compilation):
- Note our minimum required autoconf/automake versions in the
appropriate locations. Closes ticket 17732.
o Dependency updates:
- Tor now uses Autoconf version 2.63 or later, and Automake 1.11 or later
(released in 2008 and 2009 respectively). If you are building Tor from
the git repository instead of from the source distribution, and your
tools are older than this, you will need to upgrade.
Closes ticket 17732.
......@@ -3,6 +3,7 @@ dnl Copyright (c) 2004-2006, Roger Dingledine, Nick Mathewson
dnl Copyright (c) 2007-2015, The Tor Project, Inc.
dnl See LICENSE for licensing information
AC_PREREQ([2.63])
AC_INIT([tor],[0.2.8.1-alpha-dev])
AC_CONFIG_SRCDIR([src/or/main.c])
AC_CONFIG_MACRO_DIR([m4])
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment