Commit 50d77ad4 authored by Sebastian Hahn's avatar Sebastian Hahn
Browse files

Fix the new warnings during autogen.sh

Follow-up fix to 3d6e2830 for configure.in additions in master that
weren't in maint-0.2.2
parent 544a8afe
......@@ -359,7 +359,7 @@ if test "$enable_bufferevents" = "yes" ; then
# Check for the right version. First see if version detection works.
AC_MSG_CHECKING([whether we can detect the Libevent version])
AC_COMPILE_IFELSE([
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#include <event2/event.h>
#if !defined(LIBEVENT_VERSION_NUMBER) || LIBEVENT_VERSION_NUMBER < 10
#error
......@@ -367,13 +367,13 @@ int x = y(zz);
#else
int x = 1;
#endif
], [event_version_number_works=yes; AC_MSG_RESULT([yes]) ],
])], [event_version_number_works=yes; AC_MSG_RESULT([yes]) ],
[event_version_number_works=no; AC_MSG_RESULT([no])])
if test "$event_version_number_works" != 'yes'; then
AC_MSG_WARN([Version detection on Libevent seems broken. Your Libevent installation is probably screwed up or very old.])
else
AC_MSG_CHECKING([whether Libevent is new enough for bufferevents])
AC_COMPILE_IFELSE([
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#include <event2/event.h>
#if !defined(LIBEVENT_VERSION_NUMBER) || LIBEVENT_VERSION_NUMBER < 0x02000700
#error
......@@ -381,7 +381,7 @@ int x = y(zz);
#else
int x = 1;
#endif
], [ AC_MSG_RESULT([yes]) ],
])], [ AC_MSG_RESULT([yes]) ],
[ AC_MSG_RESULT([no])
AC_MSG_ERROR([Libevent does not seem new enough to support bufferevents. We require 2.0.7-rc or later]) ] )
fi
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment