Commit 90dd7dc9 authored by Taylor Yu's avatar Taylor Yu
Browse files

Check for libzstd >= 1.1

The consensus compression code depends on a streaming compression API
that is new in libzstd-1.1.

Fixes #22413.
parent 0fbe1a2c
o Minor bugfixes (directory protocol):
- Check for libzstd >= 1.1 because older versions lack the
necessary streaming API. Fixes bug 22413; bugfix on
0.3.1.1-alpha.
......@@ -856,7 +856,7 @@ if test "x$enable_zstd" = "xno"; then
have_zstd=no;
else
PKG_CHECK_MODULES([ZSTD],
[libzstd],
[libzstd >= 1.1],
have_zstd=yes,
have_zstd=no)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment