1. 23 Oct, 2020 1 commit
    • Nick Mathewson's avatar
      Update required/recommended protocol lists more systematically · fd58e74d
      Nick Mathewson authored
      First I began with a set of candidates:
      
        The client's _required_ list starts with all the protocols
        supported by every release in 0.2.9-stable through current
        master.
      
        The client's _required_ list starts with all the protocols
        supported by every release in 0.3.5-stable through current
        master.
      
        Everybody's _recommended_ list starts with all the protocols
        supported by every release in 0.3.5-stable through current master.
      
      Then I removed the protocol versions that we do not actually want to
      require or recommend:
      
        DirCache=1 (deprecated)
        HSDir=1, HSIntro=1-3, HSRend=1 (deprecated)
        (All HS* protocol requirements for clients)
        Link=1-3 (deprecated)
        LinkAuth=1 (obsolete)
        Relay=1 (obsolete)
      fd58e74d
  2. 18 Oct, 2020 2 commits
    • Nick Mathewson's avatar
      Update required/recommended protocol versions. · d872c692
      Nick Mathewson authored
        Cons=1 is the old format of consensuses, without ed25519 keys. It
        is no longer required or recommended.
      
        Cons=2 is the new format of consensuses, with ed25519 keys. It
        is now required.
      
        (Similarly for Desc=1,2 and Microdesc=1,2)
      
      No supported client or relay versions should be affected by this
      change, since these versions are supported by clients and relays
      running 0.2.9 and later.  It will only take effect once enough
      authorities vote for it.
      
      Closes ticket 40162.
      d872c692
    • Nick Mathewson's avatar
      Split required/recommended protocol lists into multiple lines · 4298d877
      Nick Mathewson authored
      This should make diffs easier to read.
      4298d877
  3. 07 Oct, 2020 32 commits
  4. 28 Sep, 2020 2 commits
  5. 22 Sep, 2020 3 commits