Commit 60107b7d authored by juga's avatar juga
Browse files

chg: Remove support for Python 3.6

because it's already EOL. Also update dates other python releases.
parent 43942fd9
......@@ -8,11 +8,9 @@
# Python releases:
# 3.10 stable by 2021-10-04: https://www.python.org/dev/peps/pep-0619/
# Python stable releases: https://www.python.org/downloads/
# 3.9 EOL 2025-10 PEP 596
# 3.8 EOL 2024-10 PEP 569, newest major release
# 3.7 EOL 2023-06-27 PEP 537, included in Debian bullseye (Debian stable from
# 2021-08-15)
# 3.6 EOL 2021-12-23 PEP 494
# 3.9 EOL 2025-10, PEP 596
# 3.8 EOL 2024-10, PEP 569
# 3.7 EOL 2023-06-27, PEP 537
variables:
BASE_IMAGE: python:3.9
......@@ -46,13 +44,6 @@ before_script:
after_script:
- tox -e stats
python36:
variables:
BASE_IMAGE: python:3.6
script:
- tox -e py36
- tox -e integration
python37:
variables:
BASE_IMAGE: python:3.7
......
......@@ -23,7 +23,7 @@ System requirements
--------------------
- Tor (last stable version is recommended)
- Python 3 (>= 3.6)
- Python 3 (>= 3.7)
Python dependencies
--------------------
......
[tool.black]
line-length = 79
target-version = ['py36', 'py37', 'py38', 'py39']
target-version = ['py37', 'py38', 'py39']
exclude = '''
/(
docs
......
......@@ -19,7 +19,6 @@ classifiers =
Natural Language :: English
Operating System :: POSIX :: Linux
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9
......@@ -34,7 +33,7 @@ project_urls =
packages = find:
include_package_data = True
# See stable releases at https://www.python.org/downloads/
python_requires = >= 3.6
python_requires = >= 3.7
install_requires =
psutil >= 5.5
stem >= 1.7.0
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment