Unverified Commit 7c462d7a authored by Georg Koppen's avatar Georg Koppen
Browse files

Bug 34388: Update lucetc and wasi-sdk projects to latest ESR 78 code

We "re-use" the same vendored tarball filename for now as lucetc has not
been used previously anyway.
parent 4f130777
......@@ -2,8 +2,8 @@
filename: '[% project %]-[% c("version") %]-[% c("var/build_id") %].tar.gz'
version: '[% c("input_file_var/rust_version") %]'
# those values can be changed from the input_files section of other
# projects. See projects/lucetc/config and bug 32436.
# Those values can be changed from the input_files section of other
# projects. See bug 32436.
input_file_var:
rust_version: 1.43.0
prev_version: 1.42.0
......
......@@ -13,11 +13,12 @@ tar -C /var/tmp/dist -xf [% c('input_files_by_name/wasi-sysroot') %]
export PATH="/var/tmp/dist/cmake/bin:/var/tmp/dist/clang/bin:/var/tmp/dist/binutils/bin:/var/tmp/dist/rust/bin:$PATH"
export CC=$distdir/clang/bin/clang
export CFLAGS="-L$distdir/clang/lib"
export CXXFLAGS=$CFLAGS
export CXX=$distdir/clang/bin/clang++
export CXXFLAGS=$CFLAGS
export AR=$distdir/clang/bin/llvm-ar
export RUSTFLAGS="-C linker=$CXX -C link-arg=$CXXFLAGS"
export LUCET_PREFIX=$distdir/[% project %]
# XXX: Why do we need that when Mozilla doesn't? See: taskcluster/scripts/misc/build-lucetc.sh
export WASI_SYSROOT=$distdir/wasi-sysroot
mkdir -p /var/tmp/build
......@@ -39,6 +40,7 @@ directory = "/var/tmp/build/lucetc/vendor"
EOF
make -j[% c("buildconf/num_procs") %] build
# XXX: Should not be needed, just the lucetc binary, see: taskcluster/scripts/misc/build-lucetc.sh
make install
cd $distdir
......
# vim: filetype=yaml sw=2
filename: '[% project %]-[% c("version") %]-[% c("var/osname") %]-[% c("var/build_id") %]'
version: '[% c("abbrev") %]'
git_hash: 5c22392b5b1aaa60e915c75e92b57391e1e61e6d
git_hash: a0a1ce981638109f1f76cd1eecf17a0436a20055
git_url: https://github.com/PLSysSec/lucet_sandbox_compiler/
git_submodule: 1
......@@ -23,13 +23,9 @@ input_files:
project: binutils
- name: rust
project: rust
input_file_var:
# lucetc needs Rust >= 1.36.0
rust_version: 1.36.0
prev_version: 1.35.0
- name: wasi-sysroot
project: wasi-sysroot
# `cargo vendor vendor` in the `lucetc-sandbox-compiler` directory has vendored
# the sources.
- URL: https://people.torproject.org/~gk/mirrors/sources/lucetc-vendor.tar.bz2
sha256sum: 5a7802834d0d4b9210f323cf69cc305946f22dba4ddaf2c4c0eb6d3621da2c2a
sha256sum: 12ba97fca12177e7ed5b5409fcfdbd31dc7db2e82282768d99dee5bcb1b1246a
......@@ -2,8 +2,8 @@
filename: '[% project %]-[% c("version") %]-[% c("var/build_id") %].tar.gz'
version: '[% c("input_file_var/rust_version") %]'
# those values can be changed from the input_files section of other
# projects. See projects/lucetc/config and bug 32436.
# Those values can be changed from the input_files section of other
# projects. See bug 32436.
input_file_var:
rust_version: 1.41.1
prev_version: 1.40.0
......
......@@ -23,6 +23,8 @@ cd $builddir
# hard-code the version for now.
patch -p1 < $rootdir/no-git.patch
# XXX: We don't want to use the clang 9.0 wasi-sdk would use, see:
# https://bugzilla.mozilla.org/show_bug.cgi?id=1605708
make -j[% c("buildconf/num_procs") %] PREFIX=$distdir/[% project %]
cd $distdir
......
# vim: filetype=yaml sw=2
filename: '[% project %]-[% c("version") %]-[% c("var/osname") %]-[% c("var/build_id") %]'
version: '[% c("abbrev") %]'
git_hash: 87b7a019472770f08d49cf3b558867dc76ea74eb
git_hash: 5225b05436ce57f01fe649f411f3ff701246628b
git_url: https://github.com/CraneStation/wasi-sdk
git_submodule: 1
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment