GitLab is used only for code review, issue tracking and project management. Canonical locations for source code are still https://gitweb.torproject.org/ https://git.torproject.org/ and git-rw.torproject.org.

Bug 40115: Update components for switch to Fenix 82

Update application-services
parent 015ff456
This diff is collapsed.
From 1818764e69145839ab33a2f885139ea320f2283f Mon Sep 17 00:00:00 2001
From: Georg Koppen <gk@torproject.org>
Date: Wed, 26 Aug 2020 15:56:49 +0000
Subject: [PATCH] 1651662
diff --git a/build.gradle b/build.gradle
index 58a4ddae..c6e0be82 100644
--- a/build.gradle
+++ b/build.gradle
@@ -4,7 +4,7 @@ buildscript {
ext.kotlin_version = '1.3.71'
ext.jna_version = '5.2.0'
ext.android_gradle_plugin_version = '3.6.0'
- ext.android_components_version = '47.0.0'
+ ext.android_components_version = '56.0.0'
ext.build = [
ndkVersion: "21.3.6528147", // Keep it in sync in TC Dockerfile.
--
2.28.0
......@@ -82,8 +82,6 @@ patch -p1 < $rootdir/no-git.patch
# XXX: We don't build the code for Linux for now as this involves additional
# complexity. That's needed for running unit tests later on, though.
patch -p1 < $rootdir/target.patch
patch -p1 < $rootdir/1651660.patch
patch -p1 < $rootdir/1651662.patch
[% IF c('var/fetch_gradle_dependencies') %]
# XXX: `assemble` is still not enough to see all fetched dependencies via
# Gradle's --debug. See: tor-browser-build#40056.
......
# vim: filetype=yaml sw=2
filename: '[% project %]-[% c("version") %]-[% c("var/build_id") %].tar.gz'
version: 61.0.13
git_hash: 8faa8313bcec03775ddaa194438391c4731eb840 # v61.0.13
version: 63.0.0
git_hash: 8e63363359c3d20385ed55f5308d19e321816898
git_url: https://github.com/mozilla/application-services
var:
......@@ -10,7 +10,7 @@ var:
# This should be updated when the list of gradle dependencies is changed.
gradle_dependencies_version: 2
# This should be updated when the list of rust dependencies is changed.
rust_vendor_version: 1
rust_vendor_version: 2
# For armv7 we need a different target than the default one we use for
# GeckoView. We set this variable so the Rust project in the `input_files`
# below can set the correct target when built for use in this project,
......@@ -24,19 +24,19 @@ input_files:
- project: '[% c("var/compiler") %]'
name: '[% c("var/compiler") %]'
# We need the torbrowser-* targets for Rust, see: #40094.
- project: fenix-rust
- project: fenix-as-rust
name: rust-armv7
target_prepend:
- torbrowser-android-armv7
- project: fenix-rust
- project: fenix-as-rust
name: rust-aarch64
target_prepend:
- torbrowser-android-aarch64
- project: fenix-rust
- project: fenix-as-rust
name: rust-x86
target_prepend:
- torbrowser-android-x86
- project: fenix-rust
- project: fenix-as-rust
name: rust-x86_64
target_prepend:
- torbrowser-android-x86_64
......@@ -85,10 +85,8 @@ input_files:
# `cargo vendor vendor` in the `application-services` directory has vendored
# the sources.
- URL: https://people.torproject.org/~gk/mirrors/sources/application-services-vendor-[% c('var/rust_vendor_version') %].tar.bz2
sha256sum: fd90572db453b5d83bc7dbb50b09d75c5019f09ee747054fdc12f42605d9da69
sha256sum: 70e02d587661e5d93dbe30ffa9265fb8b6b66ba8483f3268017ca919623688bc
- filename: no-git.patch
- filename: mavenLocal.patch
enable: '[% !c("var/fetch_gradle_dependencies") %]'
- filename: target.patch
- filename: 1651660.patch
- filename: 1651662.patch
......@@ -2,8 +2,8 @@
filename: '[% project %]-[% c("version") %]-[% c("var/osname") %]-[% c("var/build_id") %].tar.gz'
# The required versions for application-services can be found at the respective
# commit in libs/build-all.sh
version: 3.53.1
nspr_version: 4.25
version: 3.56
nspr_version: 4.28
var:
container:
use_container: 1
......@@ -19,7 +19,7 @@ input_files:
project: ninja
- URL: 'https://ftp.mozilla.org/pub/security/nss/releases/NSS_[% c("version") | replace("\\.", "_") %]_RTM/src/nss-[% c("version") %]-with-nspr-[% c("nspr_version") %].tar.gz'
name: nss
sha256sum: 132ce527f3963e3ae5be3337ed4e1099e160b9402be177b5704de3ed2f5271d2
sha256sum: 989b548aa5589d15e31a306218d3c48dbc472b6043b78c6846b5acc54ebfed67
- filename: configure.patch
- filename: config.patch
- filename: bug_13028.patch
......@@ -2,7 +2,7 @@
filename: '[% project %]-[% c("version") %]-[% c("var/osname") %]-[% c("var/build_id") %].tar.gz'
# The required versions for application-services can be found at the respective
# commit in libs/build-all.sh
version: 4.3.0
version: 4.4.0
var:
container:
use_container: 1
......@@ -18,4 +18,4 @@ input_files:
project: nss
- URL: 'https://github.com/sqlcipher/sqlcipher/archive/v[% c("version") %].tar.gz'
name: sqlcipher
sha256sum: fccb37e440ada898902b294d02cde7af9e8706b185d77ed9f6f4d5b18b4c305f
sha256sum: 0924b2ae1079717954498bda78a30de20ce2a6083076b16214a711567821d148
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment