1. 31 Jul, 2017 1 commit
  2. 13 Jun, 2017 1 commit
    • boklm's avatar
      Update versions and ChangeLog for 7.5a1 · 48e45a9a
      boklm authored
      tor-browser-bundle.git author: Georg Koppen <gk@torproject.org>
      tor-browser-bundle.git commit: 321ad6021df0b3d55625c5bd88dcfc5acdf112f8
      tor-browser-bundle.git commit: ade53c43e1230a05e0b138b3ade92914e9d9a279
      tor-browser-bundle.git commit: 638da360d67407b2866f0747a5df40d8ae36af78
      48e45a9a
  3. 17 May, 2017 1 commit
    • boklm's avatar
      Bug 22194/20683: Integrate Selfrando into alpha Linux builds · 16d87451
      boklm authored
      Selfrando is a new defense against code reuse attacks developed by the
      Redactor and Readactor++ people. We should give it a wider testing
      audience by including it in the alpha series.
      
      This is currently only available for 64bit Linux builds, though.
      Supporting other platforms and architectures is work in progress.
      
      tor-browser-bundle.git author: Georg Koppen <gk@torproject.org>
      tor-browser-bundle.git commit: 332c5b6c16f1b0915f537a4ad5af48295f80c733
      tor-browser-bundle.git commit: 8fe0e322b950efa2456502428bee66dde8b4948a
      tor-browser-bundle.git commit: 3e752843dfa39beec844822c9f6c3dd1f80355ea
      16d87451
  4. 15 May, 2017 1 commit
  5. 08 May, 2017 1 commit
  6. 05 May, 2017 1 commit
  7. 20 Apr, 2017 1 commit
  8. 15 Apr, 2017 2 commits
  9. 12 Apr, 2017 1 commit
  10. 07 Apr, 2017 3 commits
  11. 10 Mar, 2017 1 commit
  12. 15 Feb, 2017 1 commit
    • boklm's avatar
      Use binutils 2.24, and Ubuntu-12.04 for Windows builds · 7f083aad
      boklm authored
      To be closer to what we currently have in gitian, use binutils 2.24.
      
      We also change tho OS to Ubuntu 12.04 for Windows builds, except for the
      tor-browser bundle step, where we are staying with 14.10. We are using
      14.10 in the tor-browser step because the version of python-pefile we
      use fails on Ubuntu 12.04. The reason for using a recent version of
      python-pefile is that the older versions don't work on x86_64. And we
      are using an x86_64 container because docker does not support i386
      containers. The problem is not present in gitian where we are using an
      i386 VM. An other possible solution could be to build a recent version
      of python.
      7f083aad
  13. 30 Jan, 2017 2 commits
  14. 09 Jan, 2017 2 commits