Bump the version of cldr to satisfy npm audit

There's a low severity vuln in one of cldr's deps that needs updating.
The major version bump of cldr is because it drops support for node.js
v8, which is EOL.
1 job for deps in 33 seconds (queued for 1 second)
Status Job ID Name Coverage
  Test
passed #20972
build

00:00:33