Commit ac895aa3 authored by MozLando's avatar MozLando
Browse files

Merge #8233



8233: Close #8232: Remove firebase-core dependency from lib-push-firebase r=pocmo a=jonalmeida

For Cloud Messaging, we no longer need `firebase-core` as a dependency. This removes unneeded services that can run on the device.
Co-authored-by: default avatarJonathan Almeida <jalmeida@mozilla.com>
parents 0ecf302c 34cfc821
......@@ -156,6 +156,5 @@ object Dependencies {
const val thirdparty_jna = "net.java.dev.jna:jna:${Versions.jna}@jar"
const val thirdparty_disklrucache = "com.jakewharton:disklrucache:${Versions.disklrucache}"
const val firebase_core = "com.google.firebase:firebase-core:${Versions.Firebase.core}"
const val firebase_messaging = "com.google.firebase:firebase-messaging:${Versions.Firebase.messaging}"
}
......@@ -28,7 +28,6 @@ dependencies {
implementation project(':concept-push')
implementation project(':support-base')
implementation Dependencies.firebase_core
api Dependencies.firebase_messaging
testImplementation project(':support-test')
......
......@@ -24,6 +24,9 @@ permalink: /changelog/
* Implements TopSitesFeature based on the RFC [0006-top-sites-feature.md](https://github.com/mozilla-mobile/android-components/blob/master/docs/rfcs/0006-top-sites-feature.md).
* Downloads, redirect targets, reloads, embedded resources, and frames are no longer considered for inclusion in top sites. Please see [this Application Services PR](https://github.com/mozilla/application-services/pull/3505) for more details.
* **lib-push-firebase**
* Removed non-essential dependency on `com.google.firebase:firebase-core`.
# 56.0.0
* [Commits](https://github.com/mozilla-mobile/android-components/compare/v55.0.0...v56.0.0)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment