Commit ffc89c53 authored by Sebastian Kaspari's avatar Sebastian Kaspari
Browse files

Issue #17819: Only use JCenter for specific dependencies.

parent 7609f919
......@@ -141,12 +141,36 @@ allprojects {
} else {
jcenter() {
content {
// Improve security: don't search deps with known repos.
excludeGroupByRegex RepoMatching.mozilla
excludeGroupByRegex RepoMatching.androidx
excludeGroupByRegex RepoMatching.comGoogleAndroid
excludeGroupByRegex RepoMatching.comGoogleFirebase
excludeGroupByRegex RepoMatching.comAndroid
////////////////////////////////////////////////////////////////////////////////
// JCenter is going away. Please do not add any new dependencies here.
// https://jfrog.com/blog/into-the-sunset-bintray-jcenter-gocenter-and-chartcenter/
////////////////////////////////////////////////////////////////////////////////
// Leanplum
// The docs mention a custom repository (repo.leanplum.com) that we may be able
// to switch to.
includeVersion("com.leanplum", "leanplum-core", "5.4.0")
includeVersion("com.leanplum", "leanplum-push", "5.4.0")
includeVersion("com.leanplum", "leanplum-fcm", "5.4.0")
// Used by Android Gradle Plugin
// Issue for publishing to maven central: https://youtrack.jetbrains.com/issue/IDEA-261387
// Related plugin issue: https://issuetracker.google.com/issues/179291081
// Other option: Update to Android Gradle Plugin 7+ (still in Alpha currently)
includeVersion("org.jetbrains.trove4j", "trove4j", "20160824")
// Used by detekt
// Issue for publishing to maven central: https://github.com/Kotlin/kotlinx.html/issues/173
// Related detekt issue: https://github.com/detekt/detekt/issues/3461
includeVersion("org.jetbrains.kotlinx", "kotlinx-html-jvm", "0.7.1")
includeVersion("org.jetbrains.kotlinx", "kotlinx-html-common", "0.7.1")
// Fastlane
// Doesn't seem to be available on Maven Central yet, and I couldn't find an issue for it
// https://github.com/fastlane/fastlane
includeVersion("tools.fastlane", "screengrab", "2.0.0")
// https://github.com/jraska/Falcon/issues/52
includeVersion("com.jraska", "falcon", "2.1.1")
}
}
}
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment