require-c99 523 Bytes
Newer Older
1
2
3
4
5
6
7
8
9
10
  o New compiler requirements:
    - Tor 0.2.6.x requires that your compiler support more of the C99
      language standard than before. The 'configure' script now detects
      whether your compiler supports C99 mid-block declarations and
      designated initializers. If it does not, Tor will not compile.

      We may revisit this requirement if it turns out that a significant
      number of people need to build Tor with compilers that don't
      bother implementing a 15-year-old standard. Closes ticket 13233.