Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
T
tor
Manage
Activity
Members
Labels
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
The Tor Project
Core
debian
tor
Commits
da828b28
Commit
da828b28
authored
14 years ago
by
Peter Palfrader
Browse files
Options
Downloads
Patches
Plain Diff
remove debian/patches/15_tlsext_host_name
This patch is already included in upstream's 0.2.2.19-alpha
parent
fbe6b172
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
debian/changelog
+3
-1
3 additions, 1 deletion
debian/changelog
debian/patches/00list
+0
-1
0 additions, 1 deletion
debian/patches/00list
debian/patches/15_tlsext_host_name.dpatch
+0
-67
0 additions, 67 deletions
debian/patches/15_tlsext_host_name.dpatch
with
3 additions
and
69 deletions
debian/changelog
+
3
−
1
View file @
da828b28
tor (0.2.2.19-alpha-1) experimental; urgency=low
* New upstream version.
- remove debian/patches/15_tlsext_host_name (already included in new
upstream version).
-- Peter Palfrader <weasel@debian.org> Mon, 29 Nov 2010 13:4
4:54
+0100
-- Peter Palfrader <weasel@debian.org> Mon, 29 Nov 2010 13:4
6:10
+0100
tor (0.2.2.18-alpha-2) experimental; urgency=low
...
...
This diff is collapsed.
Click to expand it.
debian/patches/00list
+
0
−
1
View file @
da828b28
...
...
@@ -3,4 +3,3 @@
06_add_compile_time_defaults.dpatch
07_log_to_file_by_default.dpatch
14_fix_geoip_warning
15_tlsext_host_name
This diff is collapsed.
Click to expand it.
debian/patches/15_tlsext_host_name.dpatch
deleted
100755 → 0
+
0
−
67
View file @
fbe6b172
#! /bin/sh -e
## 15_tlsext_host_name.dpatch
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Do not set the hostname TLS extension server-side; only client-side
if [ $# -lt 1 ]; then
echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
exit 1
fi
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
case "$1" in
-patch) patch -p1 ${patch_opts} < $0;;
-unpatch) patch -R -p1 ${patch_opts} < $0;;
*)
echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
exit 1;;
esac
exit 0
#From 92a99736fd22564515604aa140b8898befd9858e Mon Sep 17 00:00:00 2001
#From: Nick Mathewson <nickm@torproject.org>
#Date: Sat, 20 Nov 2010 22:21:50 -0500
#Subject: [PATCH] Do not set the hostname TLS extension server-side; only client-side
#
#This may fix bug 2204, and resolve the incompatibility with openssl
#0.9.8p/1.0.0b.
#---
# changes/fix2204 | 7 +++++++
# src/common/tortls.c | 2 +-
# 2 files changed, 8 insertions(+), 1 deletions(-)
# create mode 100644 changes/fix2204
#
#diff --git a/changes/fix2204 b/changes/fix2204
#new file mode 100644
#index 0000000..fb2771a
#--- /dev/null
#+++ b/changes/fix2204
#@@ -0,0 +1,7 @@
#+ o Major bugfixes
#+ - Do not set the tlsext_host_name extension on server SSL objects;
#+ only on client SSL objects. We set it to immitate a browser, not a
#+ vhosting server. This resolves an incompatibility with openssl 0.9.8p
#+ and openssl 1.0.0b. Fixes bug 2204; bugfix on 0.2.1.1-alpha.
#+
#+
@DPATCH@
diff --git a/src/common/tortls.c b/src/common/tortls.c
index 25f21a9..2915f79 100644
--- a/src/common/tortls.c
+++ b/src/common/tortls.c
@@ -898,7 +898,7 @@
tor_tls_new(int sock, int isServer)
#ifdef SSL_set_tlsext_host_name
/* Browsers use the TLS hostname extension, so we should too. */
- {
+ if (!isServer) {
char *fake_hostname = crypto_random_hostname(4,25, "www.",".com");
SSL_set_tlsext_host_name(result->ssl, fake_hostname);
tor_free(fake_hostname);
--
1.7.1
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment